NIS-Elements Viewer
User's Guide
Publication date 25.08.2020
v. 5.21.00
No part of this publication may be reproduced or transmitted except with the written permission of Laboratory Imaging s.r.o.
Information within this publication is subject to change without notice. Changes, technical inaccuracies and typographical
errors will be corrected in subsequent editions.
Laboratory Imaging s.r.o.
Za Drahou 171/17
102 00 Praha 10
Czech Republic

NIS-Elements Viewer

Table of Contents
1. Abilities ....................................................................................................................................................... 1
2. Installation .................................................................................................................................................. 3
3. Observing a file ............................................................................................................................................ 5
3.1. Viewing modes .................................................................................................................................. 5
3.2. Image window toolbar tools ................................................................................................................ 5
3.3. Control Bar ....................................................................................................................................... 5
3.4. LUTs Tools ........................................................................................................................................ 7
3.4.1. Auto Scale Settings ................................................................................................................. 8
4. Command Reference .................................................................................................................................... 9
4.1. File Menu ......................................................................................................................................... 9
4.1.1. File > Open ............................................................................................................................ 9
4.1.2. File > Open Report .................................................................................................................. 9
4.1.3. File > Export ND Document... ................................................................................................... 9
4.1.4. File > Save/Export to TIFF Files ............................................................................................... 10
4.1.5. File > Print ........................................................................................................................... 11
4.1.6. File > Recent Files ................................................................................................................ 11
4.1.7. File > Recent Folders ............................................................................................................. 11
4.1.8. File > Image Properties .......................................................................................................... 11
4.1.9. File > Exit ............................................................................................................................ 11
4.2. Window Menu ................................................................................................................................. 11
4.2.1. Window > Next ..................................................................................................................... 11
4.2.2. Window > Previous ............................................................................................................... 11
4.2.3. Window > Close All ............................................................................................................... 11
4.2.4. Window > Close All but Current ............................................................................................... 11
4.2.5. Window > Close .................................................................................................................... 11
4.2.6. Window > Show LUTs Window ................................................................................................ 11
4.2.7. Window > Cascade ................................................................................................................ 11
4.2.8. Window > Tile Horizontally ..................................................................................................... 11
4.2.9. Window > Tile Vertically ......................................................................................................... 11
4.3. Help Menu ..................................................................................................................................... 11
4.3.1. Help > Contents ................................................................................................................... 11
4.3.2. Help > Search ...................................................................................................................... 11
4.3.3. Help > How To Buy ................................................................................................................ 11
4.3.4. Help > About ........................................................................................................................ 12

iii

iv

Abilities

1. Abilities
NIS-Elements Viewer is a software created to open and view
all file formats created by NIS-Elements:

Attachments Attachment files can be opened by clicking
the icon from the toolbar or inside the image context menu.

Features

Show Binary When active, this function turns on the binary
layer previously saved in NIS-Elements.

Image Sequence Playback You can play the ND2 image
sequence as a movie or browse it frame by frame.

Exporting All images of an ND2 data-set can be saved as a
TIF, Multi-Page TIFF, ND2 or JPEG2000 file. See File Menu
> File > Export ND Document....

Views Four different views are available: Main View, Slices
View, Volume View, Tiled View.
Note
Availability of the Slices, Tiles and Volume Views depends on the document's dimensions.

LUTs Adjusting A non-destructive contrast enhancement of
the image can be applied using either the LUTs toolbar or
the LUTs window. The parameters can be adjusted manually
or automatically. Please see 3.4 LUTs Tools.
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Figure 1.1. Volume View within the NIS-Elements Viewer
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Installation

2. Installation
• Run the NIS_Viewer_x.exe setup file. The installation wizard appears.
• Follow the instructions of the wizard.
• Click Finish .
Figure 2.1. Installation wizard
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Observing a file

3. Observing a file
1. Run the [Start > Programs > NIS-Elements Viewer > NIS
Viewer] command.
2. Call the File Menu > File > Open or the File Menu > File
> Open Report command and select the file to open.
Figure 3.1. Image Open dialog window

Open Attachment Clicking this icon opens the attachment file in an associated program. If the association is
missing, user is offered to save the document to a local
drive. Attachments can also be opened/saved by clicking
Open Attachment.../Save Attachment As... inside the image
context menu.
Fit to screen Adjusts zoom to view the whole image
within the main screen.
Best Fit Adjusts zoom to fit the image window in one
direction but to fill the screen.
1:1 Zoom Adjust zoom so that one pixel of the image
matches one pixel of monitor.
Zoom In Increases magnification of the image.
Zoom Out Decreases magnification of the image.
Custom zoom Custom zoom value can be selected from the
combo box.

3. Choose from different 3.1 Viewing modes and enhance
your image with 3.4 LUTs Tools.

3.1 Viewing modes
Depending on the dimensions contained in the ND2 file, you
can display other views of the data set. These viewing modes
can be switched by four icons on the left of the main tool
bar.

Show Scale Places a scale bar into the current image.

3.3 Control Bar
Figure 3.2. A T/Z/multi-channel image with a few selected
loops (highlighted green)

Split Components Turns ON a special view, where color
channels of the image are displayed separately (tiled).
Main View When you open an ND2 file, it opens in this
view.
Slices This view displays orthogonal XY, XZ, and YZ projections of the image sequence (Requires Z or T dimension).
Tiles This view displays frames of the selected dimension
arranged one next to other (Requires Z, T or XY dimension).
Volume This view creates a 3D model of the acquired
object (Requires Z dimension).

3.2 Image window toolbar tools

When an ND2 file is opened, its structure is pictured at the
bottom of the image window.
1. There is a time line with all captured images indicated by
gray markers. The blue-highlighted marker indicates the
currently observed image frame. You can browse the ND2
file by clicking inside the time line.
2. Below the time line, loops of each dimension are indicated
by blue rectangles. Loops can be selected by mouse while
holding Ctrl or Shift keys and are highlighted
green.
Note

Besides the view modes described above, following tools
are also available:

In case of a simple single channel time-lapse ND2
image, one time loop = one image frame = one blue
rectangle. In the T/Z/MCH ND2 image (displayed
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above), one time loop contains several Z loops and
each Z loop contains 3 color channels.
Note
ND2 files may contain a very large number of frames.
It may be useful to omit some of the frames from
the selection. See Selection Context Menu.
3. Each dimension can be browsed frame-by-frame or you
can use the playback controls on the right side.
4. User events can be pinned to any frame of an ND2 image
in order to highlight a remarkable scene or action. Use
the buttons in the event bar to insert, browse and manage
them.
In specific cases the ND2 file control bar looks differently.
If the number of channels exceeds 10, the image is considered to be a spectral image and a lambda dimension is
displayed instead of the standard channel tabs.
Figure 3.3. T/Z/multi-channel image containing 11
channels and the time line hidden

Maximum Playing Speed for Every Frame On Sets the
playing speed to maximum while the display of every frame
is guaranteed (when the speed is set to maximum by the +
button, some frames are usually omitted when playing the
sequence depending on your graphics card).
Home Position Displays the frame of the Z dimension
that was set as “home” during the acquisition.
Selection Context Menu
Right-click a loop (blue rectangle) to display the selection
context menu. There are the following commands:
Note
The placeholder X is the name of the current (clicked)
dimension, i.e.: T, Z, M, ...
Select All Frames in X Selects all frames within the current
dimension. The Select Every option is reset to Every automatically.
Select Frames in X Opens a dialog where the user can
define a range of frames to be selected.
Invert Selection Inverts the current selection while preserving the Select Every option.

Figure 3.4. HDR multi-exposure image

Select Every Every Nth frame of the selection is used. First
make a selection of frames either by mouse (while holding
down Shift or Ctrl ) or select all frames using the Select All Frames command or the
button. Then choose
the Select Every option. Selection is changed to every Nth
frame of your previous frame selection.

Figure 3.5. Multi-channel image containing 11 channels

Playback Controls
Select All Frames Selects all frames of the dimension
and highlights them green.
Play Sequence Plays all images of the dimension at a
defined speed. If a selection is applied, only the selected
images are included in the playback.
Stop Playing Stops playing the sequence at the last
displayed frame.
Previous Position,
Next Position Displays the previous/next frame of the dimension.
Decrease Playing Speed,
Increase Playing Speed
Changes the playback speed by one step down/up.
Real Time Playing Speed On Sets the playing speed to
real-time (as the image was captured).
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Note
Once this option is turned on, it is applied all over again
even after making a different frame selection. To turn
this function off, switch it to Every or select all frames.
Keep Selected Frames in X, Delete Selected Frames in X
When one of these commands is called, a new image file is
created containing only the selected/deselected frames.
Select Frame (N) Selects the clicked frame and de-selects
all other frames of the current dimension.
Delete Frame (N) Deletes the clicked frame of the current
dimension and also the custom selection of frames/loops
of the other dimensions.
Note
If you want to keep all frames/loops of other dimensions, make sure you applied the Select All Frames
command to them.
Tips
• Detailed info about dimensions will be displayed after you
click the leftmost button of the control bar (T>, Z>, ...).

Observing a file

• Place the cursor over one of the dimensions. A tool-tip
which displays statistics of the dimension appears.

Figure 3.7. LUT's Control Panel

Playing options
Right-click the speed bar to display the following context
menu and select the playing mode.

Back and Forth,
Forward,
Backward Define the
direction how the image sequence will be played.
Repeat Sets the repetitive infinite playback.
Stop on Events When you select this option and then
press the
Play Sequence button, a dialog window appears once the first user event is reached. The dialog window
displays information about the reached user event. Use the
Continue button to continue playing to the next event, or
press the Stop button to stop the playback at the current
frame. Within the window, you can also select the Do not
ask again in this session (Always stop) option. Playing will
then stop automatically on every user event but the window
will not be shown.
Maximum Speed This command corresponds to the
Maximum Playing Speed for Every Frame On button described above.
Real Time This command corresponds to the
Playing Speed On button described above.

Real-Time

3.4 LUTs Tools
LUT (look-up table) is a useful tool for image color and
brightness modifications. You can use LUTs to enhance images for observation purposes so the color modifications
will be non-destructive to the image data. LUTs settings are
saved along with the image file. Adjust LUTs settings within
the central tool bar.

Enable/Disable LUTs This button applies LUTs to the
current image.
Keep Auto Scale Press this button to run the auto scale
procedure permanently (on the live image). When you turn
this button OFF, the settings remain as if the Auto Scale
button was pressed only once.
Auto Scale This button adjusts the white slider position
of all channels automatically with the purpose to enhance
the image reasonably. If you have selected the Use Black
Level option from the Settings pull-down menu, the black
slider will be affected too.
Reset All Components Discard all LUTs settings and
turn LUTs OFF by pressing this button.
Settings pull-down menu Display the pull down menu and
select one of the following commands:
• Brightfield Opacity - You can change opacity of a brightfield
channel. Define the opacity in the Brightfield Opacity dialog window that appears after you run this command.
• Use Black Level - Check this item to ensure that the black
slider will be affected by the auto scale functions.
• Settings - opens the Auto Scale Settings window. See
3.4.1 Auto Scale Settings.
Keep Auto White Balance Check Box Check this option to
switch the Auto White Balance functionality permanently (on
the live image).
AWB Press this button to perform the Auto White Balance
operation once.
Auto White Balance Color (...) This button Opens the AWB
Color window and enables you to select a color shade which
the system shall eliminate (make white).
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Reset AWB If Keep Auto White Balance or Auto White
Balance function is applied, this button turns it off.
Color Oversaturation Switch this button ON and the
system highlights all pixels with values reaching maximal
values. Select colors to highlight the pixels with in the pulldown menu.
These buttons arrange histograms of single channels next to each other horizontally or vertically.
This button arranges histograms of single channels
overlapped. Use sliders at the bottom of the graph window
to amplify or reduce the green/red/blue component display
in the view.
Save/Load LUTs This pull-down menu enables user to
handle LUTs settings in various ways. They can be saved to
a *.lut file and loaded later. Or, LUTs settings saved along
with an image can be loaded directly from this image by the
Reuse LUTs from File command. Or you can copy/paste the
settings within the documents opened in NIS-Elements.

3.4.1 Auto Scale Settings
Press the down arrow next to the
Reset LUTs button
and a pull-down menu appears. Invoke the Settings command.

The Low and High fields determine how many of all pixels
of the picture are left outside the sliders when Auto Scale
is applied (0-10%).
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Command Reference

4. Command Reference
4.1 File Menu
4.1.1 File > Open

4.1.3 File > Export ND Document...
Figure 4.2. ND Export dialog window

You can load one or more images to the application. The
Open Image dialog-box appears. Multiple files selection can
be performed holding the Ctrl or the Shift key.

This command opens the export dialog window with following
options:
Export Options
File folder Select the folder to where the images will be
saved.
Information Image properties of the selected file can be
displayed by pressing this button (in the top right corner).

File type Select the image format from the menu.

File name Typing in this edit box, you are offered files that
matches the already-typed characters pattern.

File prefix Specify the prefix which will be used to name all
files of the sequence. Dimension names and numbers will
be appended to this prefix.

Files of type Select an image format or All Images . Only the
files of the selected format will be displayed in the upper
window.

Index order You can specify the order of dimensions. Select
the This will influence the naming of the images.

Note
Time Step Definition: Some ND2 files do not have the
time step defined properly. When you are opening such
ND2 document, a dialog window appears, where the
proper time step between the frames shall be defined.

4.1.2 File > Open Report
Opens a report (*.rpt) file.

Apply LUTs Select this box to apply the current LUTs settings
to the images.
Note
Image data in the final format will be modified according to the current LUTs settings.
Insert Overlays This option merges all visible layers (binary,
annotations,...) and inserts it to the underlying image data.
If this option is used, the images are always exported as
RGB images.
Use Point Names XY point names are used if this function
is checked.
Channels There are the following ways to save color channels:
Mono image for each channel Each channel is exported as a mono image and indexed “c1, c2, ...”.
Color image for each channel Each channel is exported
as an RGB image preserving the channel color and indexed “c1, c2, ...”.
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Merge channels to RGB image Each multichannel
image will be converted to a single RGB.
Keep image as multichannel This option keeps the
channels layout of the original ND2 file.
TIF Compatibility Options When saving a tif file, you can
choose to keep the original bit depth of the new file, or to
increase/decrease it.

4.1.4 File > Save/Export to TIFF Files
Figure 4.3. Export Images to TIFF dialog window

Output Folder Defines where the TIFF files will be saved.
Same as Input can be checked to save the files into their
source folder.
Folders and Naming These combo boxes define subfolder
and file naming of the newly created TIFF files.
Standard TIFF/OME-TIFF Enables to switch between different TIFF formats.
Store into Multipage TIFF A multi-page TIFF file will be created containing its dimensions in one file.
Split to Multiple Files Dimensions are dismembered to
create multiple TIFF files.
Each File Contains Defines the basic dimension(s) of the
multi-page TIFF file.
Dimension of File Names Order of the dimensions used for
file naming.
Use Point Names Names of XY multipoints present in the
image will be used.
Use Channel Names Names of the channels present in the
image will be used.
Keep Original Channel Combination If checked, channel
combination of the source image is preserved.
Bit Depth Original bit depth of the new file can be maintained, or the file can be rescaled to 8- or 16-bits.
LUTs LUTs of the source image can be ignored (None),
automatic LUTs can be applied (Apply auto LUTs) or LUTs
saved with the image can be applied (Apply saved LUTs).
Save Color Channel per Pixel Color channels can be saved
per pixel to improve the TIFF file compatibility.
Mono Image for Each Channel Each channel will be used
to create a monochrome image.

Dialog Window Options

RGB Image for Each Channel Each channel will be used to
create an RGB image in channel color or in grayscale.

Image Info Displays basic information about the currently
selected image file together with its preview.

Burn Scale Inserts scale into the final image. The scale becomes part of the image and cannot be removed.

Current Document, All Opened Documents, Multiple Files
Determines which images will be exported to TIFF.

Burn Binary Inserts the binary data into the final image. The
binary data become part of the image and cannot be removed.

Source Files Displays/hides additional options when exporting Multiple Files.
Folder Selection Target folder for the exported TIFF files.
Include Subfolders Even images in the subfolders are listed
in the window below.
>> Feed >> Moves the selected images from the left file list
to the right. Only images in the right list will be exported to
TIFF. To remove an image from this list, click
.
TIFF Settings Displays/hides additional TIFF settings.
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Burn Annotation Inserts annotations into the final image.
The annotations become part of the image and cannot be
removed.
All Channels Merged to RGB Overlay Image One RGB image
is created from all channels available in the source image.
Note
Bit depth conversion cannot be used with spectral images.

Command Reference

Include OME Metadata OME metadata can be saved with
the TIFF file to increase the TIFF file compatibility (e.g.
proper channel designation).
Save As Saves the dialog window settings into the database
(New...) or .xml file (Save to XML file...).

4.2.2 Window > Previous
Switches to the previous opened image.

4.2.3 Window > Close All

Load Loads the dialog window settings from the database
or .xml file (Load from XML file...).

Closes all opened images.

Remove Removes the selected dialog settings from the
database.

4.2.4 Window > Close All but Current

Export Starts the TIFF exporting process.

Closes all images except the currently selected one.

Cancel Closes the dialog window without applying any settings.

4.2.5 Window > Close

Help Opens this help page.
Closes the current view.

4.1.5 File > Print
This command displays the default Print window which enables you to select a printer and send the current image to
it.

4.2.6 Window > Show LUTs Window
Displays the LUTs Control Panel. See 3.4 LUTs Tools.

4.2.7 Window > Cascade
4.1.6 File > Recent Files
Displays a pop-up menu containing the list of recently
opened files.

All opened images will be aligned in a cascade.

4.2.8 Window > Tile Horizontally

4.1.7 File > Recent Folders

All opened images will be tiled horizontally.

Displays a pop-up menu containing the list of recently
opened folders.

4.2.9 Window > Tile Vertically
All opened images will be tiled vertically.

4.1.8 File > Image Properties
Displays the Image Information window with Image Fields,
Experiment Data, Recorded Data and Acquisition Details. It
is also possible to open this window from the brief information label.

4.3 Help Menu
4.3.1 Help > Contents
Opens the NIS-Elements Viewer help file.

4.1.9 File > Exit
Exits the program.

4.3.2 Help > Search
Opens the search tab of the help file.

4.2 Window Menu
4.3.3 Help > How To Buy
4.2.1 Window > Next
Switches to the next opened image.

This command is an Internet link to the site with more information about NIS-Elements. The address is:
https://www.microscope.healthcare.nikon.com/products/software/nis-elements
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4.3.4 Help > About
Opens a window with information about the currently used
version of NIS-Elements Viewer.
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Notes:

Notes:

